#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(?:https?:)?(?:\/\/)?([^\/\?]+)"
Local $sString = "http://www.ssss.com/amazingme" & @CRLF & _
"wwww.sss.com/asdsd" & @CRLF & _
"//www.something.com/ddsd" & @CRLF & _
"www.sss.com/?asdomasd" & @CRLF & _
"www.sss.com?asdasd"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")