$re = '/^(?:https?:)?(?:\/\/)?([^\/\?]+)/mi';
$str = 'http://www.ssss.com/amazingme
wwww.sss.com/asdsd
//www.something.com/ddsd
www.sss.com/?asdomasd
www.sss.com?asdasd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);