re = /^(?:https?:)?(?:\/\/)?([^\/\?]+)/mi
str = 'http://www.ssss.com/amazingme
wwww.sss.com/asdsd
//www.something.com/ddsd
www.sss.com/?asdomasd
www.sss.com?asdasd'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end