import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^ \n"
+ "(?=(?:.*[A-Z]){1,}) \n"
+ "(?=(?:.*[a-z]){1,}) \n"
+ "(?=(?:.*\\d){1,}) \n"
+ "(?!(?:.*[!@#$%^&*()\\-_=+\\{\\};:,<.>])) \n"
+ "(.{8,30})\n"
+ "$\n";
final String string = "*Valid:\n"
+ "Martin123222222222222222222222\n"
+ "Martin123\n"
+ "maRtin123\n\n\n"
+ "*Not Valid:\n"
+ "MARTIN123\n"
+ "martin123\n"
+ "MARTIN\n"
+ "M@rtin123\n"
+ "Martin123@!\n"
+ "K!re1234\n"
+ "12345678\n"
+ "Martin 123\n"
+ "Martin1232222222222222222222222\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}