$re = '/^
(?=(?:.*[A-Z]){1,})
(?=(?:.*[a-z]){1,})
(?=(?:.*\d){1,})
(?!(?:.*[!@#$%^&*()\-_=+{};:,<.>]))
(.{8,30})
$
/mx';
$str = '*Valid:
Martin123222222222222222222222
Martin123
maRtin123
*Not Valid:
MARTIN123
martin123
MARTIN
M@rtin123
Martin123@!
K!re1234
12345678
Martin 123
Martin1232222222222222222222222
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);