import Foundation
let pattern = ##"""
^
(?=(?:.*[A-Z]){1,})
(?=(?:.*[a-z]){1,})
(?=(?:.*\d){1,})
(?!(?:.*[!@#$%^&*()\-_=+{};:,<.>]))
(.{8,30})
$
"""##
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .allowCommentsAndWhitespace])
let testString = #"""
*Valid:
Martin123222222222222222222222
Martin123
maRtin123
*Not Valid:
MARTIN123
martin123
MARTIN
M@rtin123
Martin123@!
K!re1234
12345678
Martin 123
Martin1232222222222222222222222
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)