import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^|_|[^\\w&/]+)(?:#|#)([\\wÀ-ÖØ-öø-ÿ]+)";
final String string = "Hashtags\n"
+ "#hashtag text\n"
+ "#hashtag\n"
+ "text #hashtag\n"
+ "text #1tag\n"
+ "text.#hashtag\n"
+ "text #hashtag\n"
+ "text #hashtag!\n"
+ "text #hashtag1 #hashtag2\n\n"
+ "text #hash_tagüäö\n"
+ "text #hash0tag\n"
+ "text #hash_tag\n\n"
+ "Hashtags non-ACSII\n"
+ "#хэш_тег\n"
+ "#中英字典\n"
+ "#الأبجدية\n\n"
+ "Not hashtags\n"
+ "text #1234 # Match! Because we use simplistic version. Need to further filter out.\n"
+ "&#nbsp;\n"
+ "text#hashtag\n";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}