use strict;
my $str = 'dge_ANEXO_II_F_TJ[1].pdf
dge_AneXo_II_F_TJ[1].pdf
dGe_AneXo_II_F_TJ[1].pdf // Erro "G"
dge_AneXo_Ii_j_TJ[1].pdf // Erro "j"
dge_AneXo_II_F_Tr[1].pdf // Erro "r"
dge_AneXo_II_F_TJ[TT].pdf // Erro "TT"
';
my $regex = qr/[a-z]{3}_((?i)anexo)_[A-Za-z]{1,7}_[A-Z]{1}_[A-Z0-9]{2,5}...\.pdf/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}