$re = '/[a-z]{3}_((?i)anexo)_[A-Za-z]{1,7}_[A-Z]{1}_[A-Z0-9]{2,5}...\.pdf/';
$str = 'dge_ANEXO_II_F_TJ[1].pdf
dge_AneXo_II_F_TJ[1].pdf
dGe_AneXo_II_F_TJ[1].pdf // Erro "G"
dge_AneXo_Ii_j_TJ[1].pdf // Erro "j"
dge_AneXo_II_F_Tr[1].pdf // Erro "r"
dge_AneXo_II_F_TJ[TT].pdf // Erro "TT"
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);