import Foundation
let pattern = #"[a-z]{3}_((?i)anexo)_[A-Za-z]{1,7}_[A-Z]{1}_[A-Z0-9]{2,5}...\.pdf"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
dge_ANEXO_II_F_TJ[1].pdf
dge_AneXo_II_F_TJ[1].pdf
dGe_AneXo_II_F_TJ[1].pdf // Erro "G"
dge_AneXo_Ii_j_TJ[1].pdf // Erro "j"
dge_AneXo_II_F_Tr[1].pdf // Erro "r"
dge_AneXo_II_F_TJ[TT].pdf // Erro "TT"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)