const regex = /^GET ([^\s]+).*$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^GET ([^\\s]+).*$', 'g')
const str = `GET /socview/svspring01D.htm HTTP/1.1`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);