import re
regex = re.compile(r"^GET ([^\s]+).*$")
test_str = "GET /socview/svspring01D.htm HTTP/1.1"
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)