package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([A-Z]\w*\s)+[A-Z]\w*`)
var str = `One language used for managing databases is Structured Query Language. The language was developed at International Business Machines.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}