#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)^(?=\S)(?=.*\S$)[\S ]+$"
Local $sString = " // should match" & @CRLF & _
"L" & @CRLF & _
"tháng 6" & @CRLF & _
"June" & @CRLF & _
"" & @CRLF & _
" // should not match when spaces appear in the begining or end" & @CRLF & _
" February" & @CRLF & _
"February "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")