re = /^(?=\S)(?=.*\S$)[\S ]+$/im
str = ' // should match
L
tháng 6
June
// should not match when spaces appear in the begining or end
February
February '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end