const regex = /^(?=\S)(?=.*\S$)[\S ]+$/igm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=\\S)(?=.*\\S$)[\\S ]+$', 'igm')
const str = ` // should match
L
tháng 6
June
// should not match when spaces appear in the begining or end
February
February `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}