import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\"output_path\":\")(.*?)(?=\")";
final String string = "\"output_path\":\"/data/server/output/1/test_file.txt\",\"text\":\n"
+ "\"output_path\":\"/data/server/output/2/test_file.txt\",\"text\":";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}