const regex = /({\\s.+?\s)(.*)(})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('({\\\\s.+?\\s)(.*)(})', 'gm')
const str = `{\\s39\\li0\\fi0\\ri0\\sb0\\sa0\\ql\\vertalt\\fs22 Fußzeile Zchn;}
{\\b39\\li0\\fi0\\ri0\\sb0\\sa0\\ql\\vertalt\\fs22 Fußzeile Zchn;}
{\\s39\\li0\\fi0\\ri0\\sb0\\sa0\\ql\\vertalt\\fs22 Fußzeile Zchn;}`;
const subst = `$1$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);