re = /({\\s.+?\s)(.*)(})/m
str = '{\\s39\\li0\\fi0\\ri0\\sb0\\sa0\\ql\\vertalt\\fs22 Fußzeile Zchn;}
{\\b39\\li0\\fi0\\ri0\\sb0\\sa0\\ql\\vertalt\\fs22 Fußzeile Zchn;}
{\\s39\\li0\\fi0\\ri0\\sb0\\sa0\\ql\\vertalt\\fs22 Fußzeile Zchn;}'
subst = '$1$3'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result