// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)({\\s.+?\s)(.*)(})").unwrap();
let string = "{\\s39\\li0\\fi0\\ri0\\sb0\\sa0\\ql\\vertalt\\fs22 Fußzeile Zchn;}
{\\b39\\li0\\fi0\\ri0\\sb0\\sa0\\ql\\vertalt\\fs22 Fußzeile Zchn;}
{\\s39\\li0\\fi0\\ri0\\sb0\\sa0\\ql\\vertalt\\fs22 Fußzeile Zchn;}";
let substitution = "$1$3";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}