using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^A[A-Z0-9]+$";
string input = @"ASOMETHING123
BSOMETHING
Asomelowercases
A123SOMETHINUPPERAGAIN";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}