package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^A[A-Z0-9]+$`)
var str = `ASOMETHING123
BSOMETHING
Asomelowercases
A123SOMETHINUPPERAGAIN`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}