$re = '/^A[A-Z0-9]+$/m';
$str = 'ASOMETHING123
BSOMETHING
Asomelowercases
A123SOMETHINUPPERAGAIN';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);