#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b[a-z]+((\d)|([A-Z0-9][a-z0-9]+))+([A-Z])?"
Local $sString = "camelCase" & @CRLF & _
"camelCamelCamelCse" & @CRLF & _
"camel1Case" & @CRLF & _
"camel1234CamelCase" & @CRLF & _
"camelCase1234" & @CRLF & _
"camelCase1234D" & @CRLF & _
"" & @CRLF & _
"word" & @CRLF & _
"PascalCase" & @CRLF & _
"snake_case" & @CRLF & _
"multiple words" & @CRLF & _
"word!"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")