$re = '/\b[a-z]+((\d)|([A-Z0-9][a-z0-9]+))+([A-Z])?/m';
$str = 'camelCase
camelCamelCamelCse
camel1Case
camel1234CamelCase
camelCase1234
camelCase1234D
word
PascalCase
snake_case
multiple words
word!';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);