package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b[a-z]+((\d)|([A-Z0-9][a-z0-9]+))+([A-Z])?`)
var str = `camelCase
camelCamelCamelCse
camel1Case
camel1234CamelCase
camelCase1234
camelCase1234D
word
PascalCase
snake_case
multiple words
word!`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}