using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(data-(?:[a-zA-Z0-9-]+))(?=[a-zA-Z0-9]*)(?:=[\""|\'](.*?)[\""|\'])?";
string input = @"<input data-group-validate=""true"" data-attr='what' data-id/>
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}