import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(data-(?:[a-zA-Z0-9-]+))(?=[a-zA-Z0-9]*)(?:=[\\\"|\\'](.*?)[\\\"|\\'])?";
final String string = "<input data-group-validate=\"true\" data-attr='what' data-id/>\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}