$re = '/(data-(?:[a-zA-Z0-9-]+))(?=[a-zA-Z0-9]*)(?:=[\"|\'](.*?)[\"|\'])?/ms';
$str = '<input data-group-validate="true" data-attr=\'what\' data-id/>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);