package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?i)(?:^|[,.])\s*@(\w+)`)
var str = `RT @u1, @u2, u3, @u4, rt @u5:, @u3.@u1^, rt@u3`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}