// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?i)(?:^|[,.])\s*@(\w+)").unwrap();
let string = "RT @u1, @u2, u3, @u4, rt @u5:, @u3.@u1^, rt@u3";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}