const regex = new RegExp('(?i)(?:^|[,.])\\s*@(\\w+)', 'gm')
const str = `RT @u1, @u2, u3, @u4, rt @u5:, @u3.@u1^, rt@u3`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}