#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)(?<=3\. Induction Training\n).*(?=4\. Corporate Training\/Departmental Training)"
Local $sString = "3. Induction Training" & @CRLF & _
"3.1. Line managers should assess the training needs of all new staff to their department in order to help them perform to a satisfactory standard from the outset. 3.2. They should design a departmental induction programme to meet the specific needs of individual starters, together with the Corporate Induction programme which must be attended by all new employees to the City & County of Swansea. 3.3. Newly promoted staff should also have an individual training plan in order to prepare them for their new roles and responsibilities; this should also include colleagues appointed to a supervisory/management role." & @CRLF & _
"4. Corporate Training/Departmental Training"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")