use strict;
my $str = '3. Induction Training
3.1. Line managers should assess the training needs of all new staff to their department in order to help them perform to a satisfactory standard from the outset. 3.2. They should design a departmental induction programme to meet the specific needs of individual starters, together with the Corporate Induction programme which must be attended by all new employees to the City & County of Swansea. 3.3. Newly promoted staff should also have an individual training plan in order to prepare them for their new roles and responsibilities; this should also include colleagues appointed to a supervisory/management role.
4. Corporate Training/Departmental Training';
my $regex = qr/(?<=3\. Induction Training\n).*(?=4\. Corporate Training\/Departmental Training)/msp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}