re = /(?<=3\. Induction Training\n).*(?=4\. Corporate Training\/Departmental Training)/m
str = '3. Induction Training
3.1. Line managers should assess the training needs of all new staff to their department in order to help them perform to a satisfactory standard from the outset. 3.2. They should design a departmental induction programme to meet the specific needs of individual starters, together with the Corporate Induction programme which must be attended by all new employees to the City & County of Swansea. 3.3. Newly promoted staff should also have an individual training plan in order to prepare them for their new roles and responsibilities; this should also include colleagues appointed to a supervisory/management role.
4. Corporate Training/Departmental Training'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end