import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<name>\\b[\\w-]+\\b)=(?<delimiter>[\"\"'])(?<value>[(?<=\\\\).]*?)(?&delimiter)";
final String string = "\"<Storages IP-Address =\\\"123.124.0.0\\\", Servername = \\\"UA Local Discovery Server\\\", Rechnername=\\\"WG-DE-D11001DS\\\", Comment=\\\"Lokaler OPC-UA Server\\\", Type=\\\"SimaticNET.S7\\\", Company=\\\"Company\\\"/>\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}