re = /(?<name>\b[\w-]+\b)=(?<delimiter>[""'])(?<value>[(?<=\\).]*?)(?&delimiter)/m
str = '"<Storages IP-Address =\\"123.124.0.0\\", Servername = \\"UA Local Discovery Server\\", Rechnername=\\"WG-DE-D11001DS\\", Comment=\\"Lokaler OPC-UA Server\\", Type=\\"SimaticNET.S7\\", Company=\\"Company\\"/>"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end