import Foundation
let pattern = #"(?<name>\b[\w-]+\b)=(?<delimiter>[""'])(?<value>[(?<=\\).]*?)(?&delimiter)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #""<Storages IP-Address =\"123.124.0.0\", Servername = \"UA Local Discovery Server\", Rechnername=\"WG-DE-D11001DS\", Comment=\"Lokaler OPC-UA Server\", Type=\"SimaticNET.S7\", Company=\"Company\"/>""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)