#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<!\S)#<[a-zA-Z0-9]+(?: [a-zA-Z0-9]+)*>(?!\S)"
Local $sString = "abol#<xxx%$3yyytabol>" & @CRLF & _
"#<example>" & @CRLF & _
"#<example string>" & @CRLF & _
"#<example string string string string>" & @CRLF & _
"#<specific format>" & @CRLF & _
"abol#<xxx%$3yyytabol>abol"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")