$re = '/(?<!\S)#<[a-zA-Z0-9]+(?: [a-zA-Z0-9]+)*>(?!\S)/m';
$str = 'abol#<xxx%$3yyytabol>
#<example>
#<example string>
#<example string string string string>
#<specific format>
abol#<xxx%$3yyytabol>abol';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);