re = /(?<!\S)#<[a-zA-Z0-9]+(?: [a-zA-Z0-9]+)*>(?!\S)/m
str = 'abol#<xxx%$3yyytabol>
#<example>
#<example string>
#<example string string string string>
#<specific format>
abol#<xxx%$3yyytabol>abol'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end