using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d{2}\s\w+\s\d{2}";
string input = @"randomstuff371 12 Mar 16 14 Jan 15 13 Feb 16 138more random381 stuff73f";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}