package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\d{2}\s\w+\s\d{2}`)
var str = `randomstuff371 12 Mar 16 14 Jan 15 13 Feb 16 138more random381 stuff73f`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}