$re = '/\d{2}\s\w+\s\d{2}/';
$str = 'randomstuff371 12 Mar 16 14 Jan 15 13 Feb 16 138more random381 stuff73f';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);