#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:.*?\bRationale-|Normal|List Paragraph\t(?:\d+\)[ \t]*)?)[ \t]*\K.*"
Local $sString = "List Paragraph 36) Rationale-1 - Details on the context:" & @CRLF & _
"List Paragraph 37) None." & @CRLF & _
"Normal " & @CRLF & _
"List Paragraph 38) 2 - Statement complements:" & @CRLF & _
"List Paragraph 39) Blablablabla" & @CRLF & _
"List Paragraph (1) Blablablabla" & @CRLF & _
"List Paragraph (2) Blablablabla" & @CRLF & _
"List Paragraph (3) Blablablabla" & @CRLF & _
"List Paragraph (4) Blablablabla" & @CRLF & _
"List Paragraph (5) Blablablabla" & @CRLF & _
"List Paragraph (6) Blablablabla" & @CRLF & _
"List Paragraph (7) Blablablabla" & @CRLF & _
"Normal " & @CRLF & _
"List Paragraph 40) Blablablabla" & @CRLF & _
"Normal " & @CRLF & _
"List Paragraph 41) 3 - Statement justification:" & @CRLF & _
"List Paragraph 42) Blablablabla" & @CRLF & _
"Normal " & @CRLF & _
"List Paragraph 43) Blablablabla" & @CRLF & _
"List Paragraph 44) Blablablabla" & @CRLF & _
"List Paragraph 45) Blablablabla" & @CRLF & _
"List Paragraph 46) Attached Files: Rationale-" & @CRLF & _
"Normal"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")