use strict;
my $str = 'List Paragraph 36) Rationale-1 - Details on the context:
List Paragraph 37) None.
Normal
List Paragraph 38) 2 - Statement complements:
List Paragraph 39) Blablablabla
List Paragraph (1) Blablablabla
List Paragraph (2) Blablablabla
List Paragraph (3) Blablablabla
List Paragraph (4) Blablablabla
List Paragraph (5) Blablablabla
List Paragraph (6) Blablablabla
List Paragraph (7) Blablablabla
Normal
List Paragraph 40) Blablablabla
Normal
List Paragraph 41) 3 - Statement justification:
List Paragraph 42) Blablablabla
Normal
List Paragraph 43) Blablablabla
List Paragraph 44) Blablablabla
List Paragraph 45) Blablablabla
List Paragraph 46) Attached Files: Rationale-
Normal';
my $regex = qr/^(?:.*?\bRationale-|Normal|List Paragraph\t(?:\d+\)[ \t]*)?)[ \t]*\K.*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}