import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:.*?\\bRationale-|Normal|List Paragraph\\t(?:\\d+\\)[ \\t]*)?)[ \\t]*\\K.*";
final String string = "List Paragraph 36) Rationale-1 - Details on the context:\n"
+ "List Paragraph 37) None.\n"
+ "Normal \n"
+ "List Paragraph 38) 2 - Statement complements:\n"
+ "List Paragraph 39) Blablablabla\n"
+ "List Paragraph (1) Blablablabla\n"
+ "List Paragraph (2) Blablablabla\n"
+ "List Paragraph (3) Blablablabla\n"
+ "List Paragraph (4) Blablablabla\n"
+ "List Paragraph (5) Blablablabla\n"
+ "List Paragraph (6) Blablablabla\n"
+ "List Paragraph (7) Blablablabla\n"
+ "Normal \n"
+ "List Paragraph 40) Blablablabla\n"
+ "Normal \n"
+ "List Paragraph 41) 3 - Statement justification:\n"
+ "List Paragraph 42) Blablablabla\n"
+ "Normal \n"
+ "List Paragraph 43) Blablablabla\n"
+ "List Paragraph 44) Blablablabla\n"
+ "List Paragraph 45) Blablablabla\n"
+ "List Paragraph 46) Attached Files: Rationale-\n"
+ "Normal";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}