using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<a class=\""c-item_foot.*?>(.*?)<\/a><\/div>";
string input = @"aaa<a class=""c-item_foot"" href=""/news/a/"">11r11</a></div>bbb<a class=""c-item_foot"" href=""/news/b/"">222</a></div>ccgc<a class=""c-item_foot"" href=""/news/c/"">3333a333</a></div>ddd<a class=""c-item_foot"" href=""/news/d/"">44a444444</a></div>eee";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}