// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"<a class=\"c-item_foot.*?>(.*?)<\/a><\/div>"#).unwrap();
let string = "aaa<a class=\"c-item_foot\" href=\"/news/a/\">11r11</a></div>bbb<a class=\"c-item_foot\" href=\"/news/b/\">222</a></div>ccgc<a class=\"c-item_foot\" href=\"/news/c/\">3333a333</a></div>ddd<a class=\"c-item_foot\" href=\"/news/d/\">44a444444</a></div>eee";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}