import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<a class=\\\"c-item_foot.*?>(.*?)<\\/a><\\/div>";
final String string = "aaa<a class=\"c-item_foot\" href=\"/news/a/\">11r11</a></div>bbb<a class=\"c-item_foot\" href=\"/news/b/\">222</a></div>ccgc<a class=\"c-item_foot\" href=\"/news/c/\">3333a333</a></div>ddd<a class=\"c-item_foot\" href=\"/news/d/\">44a444444</a></div>eee";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}